Nieuw in WordPress 5.6: Twenty Twenty-One, donkere modus, PHP 8 en meer

Christina Widner Laatst bijgewerkt op 29.01.2021
6 Min.
WordPress  Standaard Theme Twenty Twenty-One
Laatst bijgewerkt op 29.01.2021

Met WordPress 5.6 staat de derde en laatste major update in 2020 op het punt om te verschijnen. In dit artikel ervaar je alles wat je kunt verwachten van de nieuwe versie van WordPress, waar je op moet letten en wanneer je kunt rekenen op de update.

Over nieuwe grote updates van WordPress wordt altijd druk gediscussieerd weken voordat ze worden uitgebracht. Dit is niet in de laatste plaats te danken aan de enorme WordPress -gemeenschap, waarvan de meesten op vrijwillige basis aan de nieuwe versies werken. Bovendien bepaalt elke release waar de reis op WordPress naartoe gaat - zie in het verleden bijvoorbeeld de discussie rond de editor Gutenberg.

Overzicht: Wat verandert er met WordPress 5.6?

Met WordPress 5.6 zijn er enkele veranderingen op komst voor u als gebruiker van WordPress , die we in de volgende tekst nader zullen bekijken. Let op: de huidige stand van de betatests is nog niet definitief. Daarom kunnen er nog enkele wijzigingen zijn. Aangezien we ons echter al in het kandidaat-versiestadium bevinden, moeten mogelijke wijzigingen beperkt blijven tot kleine details.

De ontwikkeling van WordPress

U kunt altijd lezen over de voortgang van de huidige en toekomstige versies van WordPress op de WordPress .orgblog. Daar vindt u ook meer over de discussie, welke functies in het middelpunt staan.

New Standard Theme: Twenty Twenty-One

Ook nieuwe standaardproductenThemes zijn regelmatig onderwerp van discussie. Sommigen prijzen het ontwerp, anderen verwerpen het. Hier moet u zelf over beslissen - smaken verschillen nu eenmaal. WordPress noemt zijn standaardThemes klassiek naar jaren, deze keer naar het komende jaar 2021, in het Engels Twenty Twenty One.

Na de update of een nieuwe installatie, als u net begint met WordPress , vindt u de nieuwe Theme in de Theme directory onder Design -> Themes. U kunt het vanaf daar activeren of een voorbeeld van uw site bekijken zoals die eruit zou zien met Twenty Twenty-One als Theme .

Nieuw in WordPress  5.6: Twenty Twenty-One, donkere modus, PHP 8 en meer
Het Theme Twenty Twenty-One

Donkere modus is hier

Naast een nieuw uiterlijk is er één functie die steeds belangrijker is geworden, vooral de laatste jaren met de introductie op smartphones - en dat al geruime tijd door sommige theme-ontwikkelaars wordt aangeboden: de Dark Mode.

In het Customizer paneel van Themes Twenty Twenty-One kunt u nu de Dark Mode activeren onder Colors & Dark Mode. Dit zal het voor uw bezoekers comfortabeler maken om uw website in een donkere omgeving te bezoeken:

Nieuw in WordPress  5.6: Twenty Twenty-One, donkere modus, PHP 8 en meer
WordPress Customizer: Stel de Dark Mode in met Twenty Twenty-One

De Dark Mode ondersteunt de apparaatinstellingen van je bezoekers. Dus als ze de Dark Mode op hun apparaat hebben geactiveerd, wordt je pagina ook in de Dark Mode getoond. Daarnaast wordt in de rechter benedenhoek een kleine button toegevoegd waarmee je bezoekers zelf de modus kunnen in- of uitschakelen.

Dark Mode mobiel WordPress
De Dark Mode in de mobiele weergave

Auto-Update ook voor grote versies

Met WordPress 5.6 zal er ook een optie zijn voor auto-updates bij nieuwe major versies van de WordPress-core. Tot nu toe zijn er alleen auto-updates geweest voor kleine beveiligingsupdates. Daar werd al geruime tijd aan gewerkt, maar nu zou het zo ver moeten zijn.

Het belangrijkste doel van WordPress is te voorkomen dat er te veel websites zijn met verouderde versies van WordPress . Dit is om de veiligheid van de websites en het systeem te verhogen. Voor oude installaties moet de optie nog steeds bewust worden geactiveerd en krijgt een waarschuwing in het gezondheidsgedeelte van de website, onder Tools -> Staat van de website. Voor nieuwe WordPress installaties zou de optie standaard ingeschakeld moeten zijn.

Als u deze optie activeert, moet u er echter ook voor zorgen dat regelmatig back-ups worden gemaakt en dat deze gemakkelijk kunnen worden hersteld, zodat u in geval van een probleem snel kunt downgraden naar de vorige versie. U moet ook Plugins en Themes up to date houden om mogelijke incompatibiliteit te voorkomen.

Ondersteuning voor PHP 8

Op 26 november, net voor WordPress 5.6, werd nog een grote versie uitgebracht - deze van PHP. Zie onze blog post over PHP 8 met nieuwe functies, verbeteringen en mogelijke problemen bij het gebruik ervan met WordPress . Compatibiliteit van WordPress 5.6 en de nieuwe PHP versie 8 maakt ook deel uit van de geplande grote update. Het team achter WordPress schrijft hierover

WordPress heeft een lange geschiedenis om zo snel mogelijk compatibel te zijn met nieuwe PHP-versies. Deze release is geen uitzondering. 

Je moet erop letten dat alle plugins en themes ook compatibel zijn met deze versie van PHP voordat je overschakelt naar PHP 8. Dit voorkomt problemen. De ontwikkelaars wijzen hier ook op.

PHP 8 ondersteuning alleen "beta"?

WP Tavern schrijft meer over waarom upgraden naar PHP 8 moeilijk kan zijn om mee te beginnen zodra WordPress 5.6 is uitgebracht. Lees het aandachtig als u met de combinatie van de twee versies wilt werken.

Modernisering van het gebruik van jQuery

Het driestappenplan van WordPress , om het gebruik van jQuery te moderniseren, heeft in de zomer al tot discussies geleid. Want met de release van WordPress 5.5, de eerste stap van dit plan, waren er problemen op veel websites. Dit komt omdat niet alle ontwikkelaars hun Plugins en Themes hadden aangepast aan het einde van de jQuery Migrate 1.x library.

WordPress bracht toen de Plugin Enable jQuery Migrate Helper uit voor onmiddellijke hulp, die je kunt beschouwen als een soort noodoplossing op korte termijn voor degenen die problemen hadden met de overgang. In WordPress 5.6, de tweede stap van het plan, wordt deze tussenoplossing echter geacht niet meer te werken.

Zorg er dus voor dat je alle themes en plugins up-to-date houdt en controleer vooral nog eens of ze überhaupt nog steeds onderhouden worden. De aankondiging om het jQuery-gebruik te moderniseren is al maanden oud, dus er was eigenlijk genoeg tijd voor de ontwikkelaars om alle plugins en themes te updaten.

Als u momenteel de Plugin "Enable jQuery Migrate Helper" gebruikt en geen foutmeldingen ziet, zou u geen problemen moeten hebben met WordPress 5.6. Neem anders contact op met de ontwikkelaars van uw Themes en/of uw getroffen Plugins alvorens bij te werken. Tussen haakjes: de derde en laatste stap van deze upgrade volgt in maart 2021 met WordPress 5.7.

UX verbeteringen

Uiteraard zijn er bij WordPress 5.6 ook enkele veranderingen in het gebruik van WordPress. In de editor geeft het infopaneel (de kleine "i" in de linkerbovenhoek van de editor) nu ook het aantal karakters en het aantal woorden in de huidige post aan:

Nieuw in WordPress  5.6: Twenty Twenty-One, donkere modus, PHP 8 en meer
Het aantal woorden en tekens in WordPress

Dit is een belangrijke innovatie voor mediabedrijven of voor bloggers die met Lira werken of namens klanten schrijven. Want nu kunnen ze precies zien wanneer de minimale lengte van de tekst is bereikt.

Ook zijn er meer opties in het Cover-Block voor het positioneren van video's, drag & drop-functionaliteit en toetsenbordnavigatie waardoor de afzonderlijke blokken verder verbeterd zullen worden.

Toegankelijkheid met WordPress 5.6

WordPress werkt al enkele jaren aan de verbetering van het platform, zodat het zo drempelvrij mogelijk wordt. Dit doel zal ook worden nagestreefd met WordPress 5.6. Het platform is gebaseerd op de Web Content Accessibility Guidelines (WCAG) van het W3C.

Het nieuwe standaard thema Twenty Twenty-One moet "AAA-klaar" zijn, d.w.z. het hoogst mogelijke niveau van toegankelijkheid bieden. Er zijn ook enkele kleine verbeteringen en fixes bij het gebruik van WordPress.

Functies die we niet zullen zien

Naast alle functies die we net bekeken hebben, zijn er ook enkele functies die het niet gehaald hebben in de nieuwe versie van WordPress, hoewel ze oorspronkelijk daarvoor bedoeld waren. Zo wilde WordPress met de update naar 5.6 eigenlijk zowel de navigatie (dus het instellen van het menu) als de widgets (d.w.z. de creatie van de sidebar) op het Gutenberg-systeem overzetten.

Nadat zij zo ver achterliepen met het navigatiescherm dat een tijdige voltooiing niet meer mogelijk was, hebben zij deze functie uitgesteld tot WordPress 5.7. Hierdoor kwamen meer middelen vrij voor de ontwikkeling van het widgetscherm. Maar deze functie was ook gepland voorWordPress 5.7 een beetje later.

Dit is weliswaar een tegenslag, maar het heeft wel middelen vrijgemaakt om de andere functies in werking te stellen. Bijvoorbeeld de hierboven beschreven compatibiliteit met PHP 8.

Het schema voor WordPress 5.6

De werkzaamheden aan WordPress 5.6 zijn in de zomer begonnen en bevinden zich vanaf 20 oktober in de bètafase. Dit betekent dat ontwikkelaars en geïnteresseerde leden van de WordPress-community de 5.6-bèta's in hun ontwikkelomgeving kunnen installeren en grondig kunnen testen.

Het doel is om zoveel mogelijk bugs te vinden en te verhelpen voor de definitieve release. De eerste release candidate, d.w.z. de eerste van in totaal twee prerelease versies, is beschikbaar sinds 17 november. De definitieve release van WordPress 5.6 is momenteel gepland voor 8 december 2020 en staat dus voor de deur. Tussen haakjes: Voor 2021 zijn vier grote updates gepland: WordPress 5.7 in maart, WordPress 5.8 in juni, versies 5.9 in september en 6.0 in december.

WordPress 5.6: Vooruitzichten en conclusie

Als u geïnteresseerd bent in het ontwikkelingsproces van WordPress en de geplande functies, kunt u een lijst van wijzigingen en veel meer informatie uit de eerste hand over de nieuwe WordPress 5.6 hier en hier vinden.

WordPress 5.6 zal op 8 december de derde en laatste grote major update zijn, voordat we volgend jaar de ontwikkeling van 5.7 tot en met 6.0 zien. Omdat tijdens de ontwikkeling niet alles volgens plan verliep, werden sommige functies uitgesteld naar 2021. Sommige recente veranderingen zijn nog steeds van groot belang. Deze omvatten PHP 8-compatibiliteit, auto-updates van nieuwe major versies en het nieuwe standaard theme Twenty Twenty-One.

Maar met de auto-updates van grote versies en de modernisering van jQuery, brengt WordPress 5.6 ook wat potentieel voor opkomende problemen met zich mee. U kunt dit voorkomen door uw Themes en Plugins up to date te houden en ervoor te zorgen dat u geen Plugins gebruikt die niet langer wordt onderhouden. Zie onze tips voor het kiezen van WordPress Plugins. Natuurlijk moet u ook altijd regelmatig back-ups van uw site maken, zodat u in het ergste geval opnieuw kunt bouwen.

Jouw vragen over WordPress 5.6

Welke vragen heeft u over WordPress 5.6? Voel je vrij om de commentaarfunctie te gebruiken. Wilt u op de hoogte blijven van nieuwe bijdragen aan WordPress ? Volg ons dan op Twitter, Facebook of via onze nieuwsbrief.

Christina is service-editor bij BASIC thinking, een van de grootste tech-magazines in Duitsland. Haar onderwerpen zijn onder andere technologie, business en marketing. Ze werkt al vele jaren met WordPress bij BASIC thinking en aan haar eigen projecten.

Gerelateerde artikelen

Reacties op dit artikel

Laat een opmerking achter

Jouw e-mailadres zal niet worden gepubliceerd. Verplichte velden zijn met een * gemarkeerd.